Skip to content
You are reading GoQuorum development version documentation and some displayed features may not be available in the stable release. You can switch to stable version using the version box at screen bottom.

Build from source

Prerequisites

Important

Tessera version 0.10.3 or later requires Java version 11, and Tessera version 0.10.2 or earlier requires Java version 8 or 11.

Clone the Tessera repository

Clone the ConsenSys/tessera repository:

git clone https://github.com/ConsenSys/tessera.git

Build Tessera

After cloning, go to the tessera directory.

Build Tessera with the Gradle wrapper gradlew, omitting tests as follows:

./gradlew build -x test

Verify the installation with the help command:

java -jar tessera-dist/tessera-app/build/libs/tessera-app-<version>-app.jar help
ConsenSys has acquired Quorum from J.P. Morgan. Please read the FAQ.
Questions or feedback? You can discuss issues and obtain free support on Tessera Slack channel.
For paid professional support by ConsenSys, contact us at quorum@consensys.net